Pagina 1 van 2

rekenen met tijden in excel

Geplaatst: do 19-02-2015 10:50
door loopgek
Ik ben weer eens met excel aan het stoeien met trainingstijden tabellen.
Twee hulpvragen:

in de celweergave staat hij als eigenschap nu op u:mm:ss
Hoe stel ik het in dat hij de secondes ook achter de komma gaat vermelden , dus ook de 100sten?

Ik zou ook een cel willen waarin de tijd uit een andere cel wordt omgerekend naar secondes, dus dat ingevoerde gelopen tijd bijv 1:24:24,33 omgerekend wordt naar 5064,33

Wie kan me helpen?

Geplaatst: do 19-02-2015 12:15
door MaGro
De 100sten kun je toevoegen door in het 'number format' menu te kiezen voor More number formats. Kies vervolgens voor Custom en type in de invoerbalk: u:mm:ss,00 Selecteer vervolgens dit number format. (afhankelijk van de taal wordt het h:mm:ss.00)

Om de tijd uit te rekenen naar secondes --> =[cel met tijd]*24*60*60

Geplaatst: do 19-02-2015 12:19
door loopgek
MaGro schreef:De 100sten kun je toevoegen door in het 'number format' menu te kiezen voor More number formats. Kies vervolgens voor Custom en type in de invoerbalk: u:mm:ss,00 Selecteer vervolgens dit number format. (afhankelijk van de taal wordt het h:mm:ss.00)

Om de tijd uit te rekenen naar secondes --> =[cel met tijd]*24*60*60
Thanx,
werkt naar wens :-)

Geplaatst: do 19-02-2015 12:28
door loen
- rechtermuisknop -> format cells -> Custom -> hh:mm:ss.000

Als bovenstaand column A is dan zet je voor B de formule

- =A*86400 en zet de cel eigenschap op number met drie decimalen

edit; te laat :)

Geplaatst: do 19-02-2015 21:34
door loopgek
maar toch bedankt Loen!

Toch nog een vraag.
In 1 cel voer ik geboortedatum in , in de andere cel komt een wedstrijddatum.
Dan zou ik met een formule in een andere cel het verschil willen zien(dus de leeftijd van die persoon) in hele jaren. En dan dus naar beneden afgerond , want iemand van 48,9 jaar oud is nog steeds 48 en en niet 49 :-)

Geplaatst: do 19-02-2015 22:31
door Zuidplasser
loopgek schreef:maar toch bedankt Loen!

Toch nog een vraag.
In 1 cel voer ik geboortedatum in , in de andere cel komt een wedstrijddatum.
Dan zou ik met een formule in een andere cel het verschil willen zien(dus de leeftijd van die persoon) in hele jaren. En dan dus naar beneden afgerond , want iemand van 48,9 jaar oud is nog steeds 48 en en niet 49 :-)
DATUMVERSCHIL (begindatum;einddatum;eenheid). Eenheid in dit geval "y"?

Geplaatst: do 19-02-2015 23:30
door loopgek
Zuidplasser schreef:
loopgek schreef:maar toch bedankt Loen!

Toch nog een vraag.
In 1 cel voer ik geboortedatum in , in de andere cel komt een wedstrijddatum.
Dan zou ik met een formule in een andere cel het verschil willen zien(dus de leeftijd van die persoon) in hele jaren. En dan dus naar beneden afgerond , want iemand van 48,9 jaar oud is nog steeds 48 en en niet 49 :-)
DATUMVERSCHIL (begindatum;einddatum;eenheid). Eenheid in dit geval "y"?
Na wat mislukkingen ontdekte ik dat de " erbij moeten staan.
Dank voor de hulp.

Er komt later nog een laatste uitdaging. Het gaat om 5 wedstrijdavonden. Dan moet er een einduitslag komen waarbij hij uit 5 kolommen de beste 4 resultaten gaat pakken , en die bij elkaar optelt. En dan mag iemand met 3 uitslagen niet boven iemand met 3 uitslagen komen ...

Geplaatst: vr 20-02-2015 7:24
door DickB
loopgek schreef: Er komt later nog een laatste uitdaging. Het gaat om 5 wedstrijdavonden. Dan moet er een einduitslag komen waarbij hij uit 5 kolommen de beste 4 resultaten gaat pakken , en die bij elkaar optelt. En dan mag iemand met 3 uitslagen niet boven iemand met 3 uitslagen komen ...
Met =MAX(A1:E1) krijg je de maximale waarde van de cellen A1, B1, C1, D1 en E1

Met =SOM(A1:E1) krijg je het totaal van deze cellen

met =SOM(A1:E1)-MAX(A1:E1) krijg je dus de som van de 4 kleinste

Met =AANTAL(A1:E1) krijg je het aantal ingevulde (met geldige waarde) cellen.
Als 4 of 5 geen verschil maakt kun je schrijven:
=ALS(G1=5,4,G1)
Hier bevat G1 het aantal gelopen wedstrijden. Hier staat dus dat als het aantal 5 is er 4 van gemaakt moet worden, en anders de waarde die er stond. Bij 1, 2, 3 of 4 wedstrijden staat er dus het echte aantal, bij 5 wedstrijden wordt dit veranderd in 4

Je hebt dus nu 5 kolommen met (mogelijk) tijden, een veld waarin het aantal mee te tellen wedstrijden (waarbij 5 is veranderd in 4) en de som van de vier beste tijden. Sorteer nu op het aantal mee te tellen wedstrijden en de totaal tijd.

PS ik begreep ik je zin met
En dan mag iemand met 3 uitslagen niet boven iemand met 3 uitslagen komen ...
niet helemaal :roll:

PPS
Ik zie nu dat wanneer je 4 wedstrijden loopt de 3 beste worden opgeteld. dat is denk ik niet de bedoeling.
Je moet dus
=SOM(A1:E1)-MAX(A1:E1)
veranderen in =ALS(AANTAL(A1:E1)=5,SOM(A1:E1)-MAX(A1:E1),SOM(A1:E1))

Hier staat dus:

Code: Selecteer alles

ALS(AANTAL(A1:E1)=5,     Als het aantal = 5 =>
SOM(A1:E1)-MAX(A1:E1),   tel de 4 (van 5) kleinste tijden op
                         ANDERS
SOM(A1:E1))              tel alle tijden op

Geplaatst: vr 20-02-2015 8:28
door pcmaal
loopgek schreef: Er komt later nog een laatste uitdaging. Het gaat om 5 wedstrijdavonden. Dan moet er een einduitslag komen waarbij hij uit 5 kolommen de beste 4 resultaten gaat pakken , en die bij elkaar optelt. En dan mag iemand met 3 uitslagen niet boven iemand met 3 uitslagen komen ...
Formule van DickB gebruiken en daarnaast een hulpkolom maken met de formule: =ALS(AANTAL(A1:E1)>=4;1;ALS(AANTAL(A1:E1)=3;;ALS(AANTAL(A1:E1)=2;3;4))) met behulp van "aangepast sorteren" kan je de uitslagen eerst laten sorteren op deze kolom en daarna de kolom waarin je de formule van DickB heb staan.

Geplaatst: vr 20-02-2015 17:46
door dano
DickB schreef:
loopgek schreef: Er komt later nog een laatste uitdaging. Het gaat om 5 wedstrijdavonden. Dan moet er een einduitslag komen waarbij hij uit 5 kolommen de beste 4 resultaten gaat pakken , en die bij elkaar optelt. En dan mag iemand met 3 uitslagen niet boven iemand met 3 uitslagen komen ...
Met =MAX(A1:E1) krijg je de maximale waarde van de cellen A1, B1, C1, D1 en E1

Met =SOM(A1:E1) krijg je het totaal van deze cellen

met =SOM(A1:E1)-MAX(A1:E1) krijg je dus de som van de 4 kleinste

Met =AANTAL(A1:E1) krijg je het aantal ingevulde (met geldige waarde) cellen.
Als 4 of 5 geen verschil maakt kun je schrijven:
=ALS(G1=5,4,G1)
Hier bevat G1 het aantal gelopen wedstrijden. Hier staat dus dat als het aantal 5 is er 4 van gemaakt moet worden, en anders de waarde die er stond. Bij 1, 2, 3 of 4 wedstrijden staat er dus het echte aantal, bij 5 wedstrijden wordt dit veranderd in 4

Je hebt dus nu 5 kolommen met (mogelijk) tijden, een veld waarin het aantal mee te tellen wedstrijden (waarbij 5 is veranderd in 4) en de som van de vier beste tijden. Sorteer nu op het aantal mee te tellen wedstrijden en de totaal tijd.

PS ik begreep ik je zin met
En dan mag iemand met 3 uitslagen niet boven iemand met 3 uitslagen komen ...
niet helemaal :roll:

PPS
Ik zie nu dat wanneer je 4 wedstrijden loopt de 3 beste worden opgeteld. dat is denk ik niet de bedoeling.
Je moet dus
=SOM(A1:E1)-MAX(A1:E1)
veranderen in =ALS(AANTAL(A1:E1)=5,SOM(A1:E1)-MAX(A1:E1),SOM(A1:E1))

Hier staat dus:

Code: Selecteer alles

ALS(AANTAL(A1:E1)=5,     Als het aantal = 5 =>
SOM(A1:E1)-MAX(A1:E1),   tel de 4 (van 5) kleinste tijden op
                         ANDERS
SOM(A1:E1))              tel alle tijden op
Volgens mij is dit niet goed want dan telt hij ook de resultaten van mensen die drie keer hebben gelopen op. En ik kan me sterk vergissen maar het gaat om een totaal tijd van vier races. Dus als je er vier loopt dan tellen ze alle 4 en anders telt de langzaamste niet. Dit moet het zijn
ALS(AANTAL(A6:A10)<4;"";ALS(AANTAL(A6:A10)=4;SOM(A6:A10);SOM(A6:A10)-MAX(A6:A10)))

Voorwaarde van deze formule is overigens wel dat een cel gewoon leeg blijft als de race niet gelopen is, en niet een tijd van nul neerzet.

En voor de burgerleeftijd GEHEEL((B17-A17)/365). Datumverschil is helemaal niet nodig

Geplaatst: vr 20-02-2015 18:53
door Zuidplasser
dano schreef: En voor de burgerleeftijd GEHEEL((B17-A17)/365). Datumverschil is helemaal niet nodig
Als er geen schrikkeljaren zouden bestaan. 365,25 is niet nauwkeurig genoeg als er op een verjaardag gelopen wordt.

Iemand die geboren is op 1 maart in een schrikkeljaar is 3 van de 4 jaar fout.

Geplaatst: vr 20-02-2015 19:49
door DickB
dano schreef: Volgens mij is dit niet goed want dan telt hij ook de resultaten van mensen die drie keer hebben gelopen op. En ik kan me sterk vergissen maar het gaat om een totaal tijd van vier races.
Nou, om nu meteen te schrijven dat dit niet goed is... :roll:

Ik heb nergens gelezen dat lopers met 3 of minder wedstrijden niet mee tellen, alleen dat ze niet boven de vier-wedstrijd-lopers mogen staan. :wink:

Geplaatst: vr 20-02-2015 20:38
door loopgek
DickB schreef:
dano schreef: Volgens mij is dit niet goed want dan telt hij ook de resultaten van mensen die drie keer hebben gelopen op. En ik kan me sterk vergissen maar het gaat om een totaal tijd van vier races.
Nou, om nu meteen te schrijven dat dit niet goed is... :roll:

Ik heb nergens gelezen dat lopers met 3 of minder wedstrijden niet mee tellen, alleen dat ze niet boven de vier-wedstrijd-lopers mogen staan. :wink:
Ja de rangschikking wordt: eerst iedereen met (minimaal) 4 resultaten, en daarvan de beste 4.
Daaronder degene die de 4 keer niet haalden.

Best grappig dat dat ik de helft van de antwoorden niet echt snap, maar als ik het dan gewoon in excel zet het wel blijkt te werken :P

Geplaatst: za 21-02-2015 9:28
door dano
Zuidplasser schreef:
dano schreef: En voor de burgerleeftijd GEHEEL((B17-A17)/365). Datumverschil is helemaal niet nodig
Als er geen schrikkeljaren zouden bestaan. 365,25 is niet nauwkeurig genoeg als er op een verjaardag gelopen wordt.

Iemand die geboren is op 1 maart in een schrikkeljaar is 3 van de 4 jaar fout.

Ik zie het ja. Voor mijn werk reken ik altijd voor leeftijden in jaren en maanden in verband met tariefbepaling of opbouw aanspraken, voorzieningen of voor premiebepaling op 1-1 met burgerleeftijd. Dus schrikkeljaar is voor mijn werk niet van belang, maar het kan dus wel verschil uitmaken. :-) Ik leer nog steeds bij ondanks bijna 20 jaar vrijwel dagelijks 70% van de tijd met excel te werken

Geplaatst: zo 19-07-2015 14:14
door Manon
En nu een vraag van mij.

Ik heb een bestandje met mijn baanwedstrijden geïmporteerd, maar daarbij staan de minuten en seconden in een apart kolommetje. Hoe kan ik die samenvoegen tot 1 tijd?
Ik had bedacht om ze op te tellen, maar het lukt mij niet om de ene kolom als "minuten" te definiëren en de andere kolom als "seconden".
Dus heb ik alles in seconden omgerekend en opgeteld. Maar hoe krijg ik al die seconden nu weer naar de mooie notatie 2:19,29? Is daar een manier voor?

Of is er een andere manier om dit te doen?